Help - Search - Members - Calendar
Full Version: Why do I have lag?
iGrandTheftAuto.com Forums > GTA IV Series > GTA IV
lordrott
Hi people, I'm Gonzalo. I'm from Argentina, so please excuse my misspellings and grammar errors.

The reason why I'm here is that I have a notebook that should run GTA4 smooth and nice but it doesn't:

i7 1.6 ghzx4 (1333mhz fsb up to 2.8 ghz)
4 GB RAM DDR3
320GB 7200RPM HD (x2)
GFORCE 230GT 1GB
WIN 7

I can play with no major issues, but I have an about 1-2 seconds delay between pressing a key for punching and nikko's punch. The same happens when I drive; I can go up to 300km/h with no problem, but when I try to get a corner, or even make the slight change of direction of my car, the game freezes 1 sec and then goes on.

It's pretty anoying, and the worst is that I don't know why.

Do you think that you can help me?

PS: I have all the drivers updated, no background programms running and my wifi turned off when I play.

THANKS A LOT for any kind of advice or tip.

ConQueSteD
it sounds as if your processor cannot handle it 100%, also make sure you have all the latest patches for the game.
lordrott
QUOTE (ConQueSteD @ Mar 29 2010, 04:06 PM) *
it sounds as if your processor cannot handle it 100%, also make sure you have all the latest patches for the game.


Thanks for your answer ConQueSted.
So, besides the game patches, you think that I have to "configure" the i7 giving certain priority to the game?

Thanks again
ConQueSteD
I would give it a try, as laptops are not meant for gaming as the CPU doesn't hold well, Desktops should always be the choice if you do high amounts/extended of computer gaming.
lordrott
QUOTE (ConQueSteD @ Mar 29 2010, 04:28 PM) *
I would give it a try, as laptops are not meant for gaming as the CPU doesn't hold well, Desktops should always be the choice if you do high amounts/extended of computer gaming.

Great. I'll search how set the priority to the processors (if you have any clue, would be great).
I use the laptop for work stuff, in fact, GTA4 is the only game I have.

this video is the GTA running almost the same laptop i have (the only difference is the size of the monitor) and there's no lag or freeze at all running with all graphics at 100%
ConQueSteD
Have you tried the patches, because I had some issues similar to that but i did the patches and it solved most of the problems.
lordrott
QUOTE (ConQueSteD @ Mar 29 2010, 11:01 PM) *
Have you tried the patches, because I had some issues similar to that but i did the patches and it solved most of the problems.

The official ones or the user made ones?
ConQueSteD
Official patches would be the best route to take. Which can be found HEREl
lordrott
QUOTE (ConQueSteD @ Mar 30 2010, 01:33 AM) *
Official patches would be the best route to take. Which can be found HEREl

Thank you very much. As soon as I can, I will give it a try and tell you how things gone..

Thanks a lot again
ThePaleOgre
Dont know if your problem is fixed yet but I remember reading something very similiar to this for another game being solved by changing something with how the laptop handles power. Like maybe set it to "game mode" or something like that I guess. I dont know much about how laptops deal with power consumption and priority for it and such but eh figured I might as well try to help.
ConQueSteD
Most laptop's aren't built for gaming because of the processors they have and I think thats the issue here is that his processor can't handle GTA.
lordrott
QUOTE (ConQueSteD @ Mar 30 2010, 01:33 AM) *
Official patches would be the best route to take. Which can be found HEREl


THANK YOU A LOT!
now it runs perfectly smooth with everything in HIGH.
the solution was just installing the update 1.0.0.4

you are my new demigod, right now biggrin.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.