IPB

Welcome Guest ( Log In | Register )

> Can't play GTAIV, The game runs slow and freezes frequently
masilli
post Sep 14 2009, 02:57 PM
Post #1


Upstanding Citizen


Group: Members
Posts: 2
Joined: 31-October 06
From: Funchal, Portugal
Member No.: 33,284
XBL Gamertag: masilli
PSN Name: masilli



Hi!

(I couldn't find a Support forum, so I'll post my issue here. Sorry if this is not the right place.)

I installed GTAIV a month ago, but the game isn't running well, and I can't find any solution for my problem.

With the default graphic settings, I get 20 fps average during day, 16 fps at night and about 10 fps when it rains. But the real problem is that after some minutes of gameplay, the game starts lagging, it goes real slow and then freezes, with the background sound/music still going. I can't do anything else except reset my machine.

I've already lowered my graphic settings several times without any luck, both resolution and detail levels. I've searched around forums, and tested some possible solutions, but none worked for me. sad.gif

Here is my full system specifications:
CPU: Intel C2Q Q6600 (no OC)
Motherboard: Gigabyte P35-DQ6
RAM: 4GB Corsair XMS2-6400C5
HDD: 2 x WD Raptor-X 150Gb - Raid_0
VGA: Sapphire ATi Radeon HD4850 512Mb (replaced)
Sound Card: Audigy 2 ZS
OS: Windows 7 Ultimate x64 RC

Can it be Windows 7 causing this issues? I know the OS recommend is either Vista SP1 or XP SP3, but Windows 7 is almost out, and I already pre-ordered one.

I've already sent a support request to Rockstar Games, but I haven't got any answer from them, and it has already passed 3 weeks.

After I tried those possible solutions I replaced my graphic card (Sapphire ATi Radeon HD4850 512Mb) with a Palit GeForce GTX 260 Sonic 216 SP 896 MB. The overall graphics have improved a lot, so has the viewing distance detail. But the game is still lagging and freezing. sad.gif

I've noticed that when the game starts freezing, the HDD activity is very high. Is it possible that this game has compatibility issues with Raid_0?

Is anyone else having troubles with the PC version?

Do you have any suggestions for me?
Achievements
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
mrcreativity
post Oct 2 2009, 08:01 AM
Post #2


Upstanding Citizen


Group: Members
Posts: 1
Joined: 18-June 05
Member No.: 14,747



I dont think its Windows 7. In fact, the game runs a whole let better on my laptop after I installed Windows 7 Ultimate x32. Performance was piss poor with Vista Home Premium SP2. I've even decided do upgrade to Windows 7 when it come out just for GTA 4.

The laptop did crash occasionally requiring a reboot before...but that blowing compressed into the exhaust vent to clean out the heat sink took care of that.

I do have almost everything low or off and running at a resolution of 1024x600.

It does slow down occasionally when there's a lot of traffic or during police chases. Otherwise, it works rather well.

My config:

Intel Core 2 Duo 5750 2.0 Ghz
2 GB Ram
ATI Radeon Mobility HD 2600 256MB RAM

This post has been edited by mrcreativity: Oct 2 2009, 08:03 AM
Achievements
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 21st October 2014 - 09:12 AM

GTA 5 | GTA San Andreas | Red Dead Redemption | GTA 4